
Supplementary material to “Unsupervised
cell segmentation by fast Gaussian

Processes”

The supplement material provides additional results for the image segmentation. In
Section S1, we discuss and demonstrate the benefit of smoothing via GP before employing
segmentation methods. In Section S2, we discuss how the threshold for the optimal criterion
given in Equation (3.1) was selected. In Section S3, we introduce a method to detect and re-
threshold the noisy sub-images with abnormally high object counts. The detail of the flood
fill algorithm is introduced in Section S4. Additional figures for the watershed algorithm are
provided in Section S5. Additional results for simulated studies and real experiments are
provided in Section S6 and Section S7, respectively. Section S8 produces the segmentation
process for the ImageJ. The ground truth mask generation and specifications of microscopy
images are discussed in Section S9 and Section S10, respectively.

S1 Segmentation without GP smoothing

GP regression is used in two steps for image segmentation. The first step is to use a
separable GP to denoise the image as discussed in Section 3.1, and the second step is to
smooth the difference of pixel counts satisfying a sequence of threshold values for generating
binary cell masks as discussed in Section 3.2. In order to demonstrate how incorporating
GP into the thresholding workflow improves results, the numerical analysis outlined in
Section 5 was repeated to compare the GP results with two approaches. The first approach
removes GP regression in both steps, and the results are compared in Figure S1. The
second method only removes GP regression for denosing the image discussed in Section
3.1, and the results are compared in Figure S2.

Panel (A) of Figure S1 shows the AP with different thresholds by the two methods for
five images of cell nuclei. The solid line representing the AP for the GP-based method is
again almost always above the dashed line representing the AP of the segmentation results
with GPs in two steps, with the same color for all thresholds, meaning that the segmentation
method with GPs consistently achieves higher AP scores than the segmentation without
GPs. The two segmentation methods only perform similarly for one image (Test Image
2). Panel (B) in Figure S1 shows the distribution of these AP scores from segmentation
methods with and without GP at each threshold. Similar to the results in panel (A),
the GP-based method achieves higher median AP scores across all thresholds. The true
annotated boundaries, those generated by the GP-based method, and those generated by
the segmentation method without GP of the fifth test image are plotted in Figure S1 (C)-
(E). The segmentation method without GP tends to over-segment cells, resulting in many
cells being split in half.

This comparison is repeated for the segmentation method where GP is only used for
smoothing the threshold as described in Section 3.2, and the results are displayed in Figure
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Figure S1: Results for segmenting cell nuclei using the proposed GP method, and the
method without GPs for image noise reduction in Section 3.1 and for smoothing the dif-
ference in pixel counts in Section 3.2. (A) AP scores for GP-based segmentation and
segmentation method with GP models removed across different thresholds. (B) Boxplots
of AP scores for each method. (C) True boundaries of the fifth test image with 1024×1024
pixels. (D) Boundaries generated by the GP-based method for the fifth test image. (E)
Boundaries generated using the segmentation method with GP models removed for the
fifth test image.

S2. Panel (A) of Figure S2 demonstrates similar results to the previous comparison, and
once again, the two segmentation methods only perform similarly for one image. For all
other images, the GP-based segmentation results yield higher APs for each threshold. Panel
(B) in S2 shows the distribution of the APs of each segmentation method, and the GP-based
method consistently achieves higher median AP scores across all thresholds. Finally, the
true annotated boundaries, those generated by the GP-based method, and those generated
by the segmentation method without the GP for image smoothing of the fifth test image
are plotted in Figure S2 (C)-(E). In Panel (E), many areas of the image have an extremely
high concentration of erroneously detected boundaries. This indicates the GP used for
denoising is crucial, as it enables the use of the thresholding method for cell segmentation
demonstrated in Figure 2.
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Figure S2: Results for segmenting cell nuclei using the proposed GP method, and the
method without GPs for image noise reduction. (A) AP scores for GP-based segmentation
and the segmentation method with GP image smoothing removed across different thresh-
olds. (B) Boxplots of AP scores for each method. (C) True boundaries of the fifth test
image with 1024× 1024 pixels. (D) Boundaries generated by the GP-based method for the
fifth test image. (E) Boundaries generated using the segmentation method with GP image
smoothing removed for the fifth test image.

S2 Sensitivity analysis of threshold α∗k
As per Equation 3.1 in the main text, the optimal threshold α∗k is set when the smoothed
differences in foreground pixel counts ∆c∗k(αm) stabilize, and the absolute difference of dif-
ferences ∆c∗k(αm−1) − ∆c∗k(αm) fall below 0.05τk, as described in Section 3.2. The cutoff
0.05τk was determined empirically, as multiplying τk by a factor of 0.05 tends to retrieve
binary images that preserve the true cell shape while still maintaining enough image infor-
mation (see Figure S3).

S3 Re-thresholding noisy sub-images with abnormally

high object counts

This section discusses a rare scenario where a sub-image has large noise that results in
abnormally high object counts compared to other sub-images in the thresholding step
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Figure S3: Empirical sensitivity analysis for α∗k cutoff. (A) When the α∗k cutoff is set
to 0.01τk, the cell mask information does not describe the entire shape, as the threshold
lies well above the base of the cell (see bottom row). (B) The α∗k cutoff is set to 0.05τk
as described in the study methods. This cutoff retrieves binary masks that are a strong
representation of the true cell shape. (C) When the α∗k cutoff is set to 0.1τk, the cell masks
are still somewhat representative of the true cell shape. However, the outlines become
slightly more jagged and irregular, particularly in the bottom cells in the binary mask
output. (D) When the α∗k cutoff is set to 2.5τk, noise distorts the binary mask output,
indicating that a larger cutoff is not effective.

discussed in Section 3.2. This scenario only happened once for all the sub-images in this
study, and it can be easily avoided by applying the average threshold calculated from the
other sub-images introduced below.

After a threshold is set for each sub-image to get the binary sub-images as described
in the main text in Section 3.2, each object group is separated and detected via flood fill
[1] discussed in Section S4. The flood fill operation assigns a unique label to each group of
connecting pixels in a binary image, including both the background and foreground pixels,
so the foreground object count is equal to the number of labels excluding the background
label. Most binary sub-images have an expected object count by inequality (S1) and are
re-incorporated into the segmentation workflow as described in the top row of Figure S4.
However, one sub-image in this study had a higher-than-expected object count due to ex-
treme noise, which is an indicator that the detected threshold by the criterion outlined in
Section 3.2 is not optimal for that binary sub-image. To control for similar edge cases, we
can use information from other sub-images in order to re-threshold the outlier image.

For a cell image made up ofK sub-images, let each binary sub-image Bk, k ∈ {1, 2, ..., K},
calculated from the predictive mean sub-images have object count Sk. Each binary sub-
image was generated by each optimal threshold α∗ set by the criterion. The outlier object
counts are determined by the following inequality:
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|Sk − S| > 2× σS, (S1)

where S is the mean object count of {S1, S2, ..., SK}, and σS is the standard deviation of
the object counts. For each binary sub-image Bk where this inequality is true, the binary
threshold of the sub-image predictive mean F∗k is reset to the mean threshold α (excluding
the thresholds of the outlier images), and the binary sub-image Bk is updated. An example
of this process for the edge case is given in the bottom row of Figure S4. Then, returning
to the original workflow, the binary sub-images are restitched to form a single binary image
representing the original cell image.

Figure S4: Workflow of determining the true optimal threshold for selected sub-images. (A)
The original image is cropped into six equal parts, and the predictive means are generated
via GPs. (B) The initial thresholds α∗k for the predictive means of two cropped images are
determined using the criterion described in Section 3.2. (C) The number of objects in the
binary sub-images is detected by flood fill. In the bottom row, despite there only being
12 cells, image noise coerces random pixel groups to be detected as foreground, leading to
over 500 objects being detected in the binary sub-image. This rare scenario only happened
once. (C.2) By inequality in (S1), this sub-image is determined to have an unusually high
object count. The sub-image threshold is reset to the average of all non-outlier sub-image
thresholds. (C.3) Twelve objects are detected after watershed and filtering based on the
cell sizes discussed in Section 3.3. (D) The binary sub-images are stitched, maintaining the
spatial continuity of the original image.

S4 Flood fill algorithm

Distinct objects in a binary image are visually separable, as each cell object is represented
with foreground pixels. However, all cell pixels in the binary image are represented by
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Figure S5: (A) An example binary image of two connecting cells. (B) Corresponding
negative distance map in the watershed algorithm.

(xi,1, xj,2) = 1. To separate these pixel clusters, connecting foreground pixels can be rela-
beled using the flood fill operation by using the bwlabel() function from EBImage package
[8]. The flood fill operation is a polygon-filling algorithm that identifies and fills regions of
connected pixels with a new specified value. The algorithm checks the adjacent pixels in
four directions (up, down, left, and right) of the starting pixel for matching values. After
specifying a starting point, the flood fill algorithm groups the connected pixels of the same
value with the same label [1]. This process is repeated until all foreground pixel clusters
have a unique identification number.

S5 Additional figures for watershed simulation

Figure S5 provides the binary image and negative distance map of an example of two
connecting cells utilized in the watershed algorithm introduced in Section 3.3. The distance
map gives the distance between each pixel and the closest background pixel in the binary
image [2]. The negative distance map −D is the negative of the distance map calculated
from the binary image B∗ [8]:

−D(xi,j) =

− min
{xi′,j′ :B

∗(xi′,j′ )=0}
‖xi,j − xi′,j′‖2, if B∗(xi,j) = 1,

0, if B∗(xi,j) = 0.

The watershed algorithm is applied to the negative distance map to segment cell objects
[8].

S6 Additional results of simulated studies

Figure S6 illustrates the ground truth of the mean of the observations, noisy observations,
and the predictive mean by fast GPs with the separable Matérn kernel in Equation (2.3)
for the Branin function and linear diffusion equation described in Example 1 in the main
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Figure S6: (A) True mean generated by Branin function. (B) Noisy observations of Branin
function (σ0 = 10). (C) Predictive mean of Branin function by GPs on lattice data with
Matérn kernel. (D) True mean generated by the linear diffusion equation. (E) Noisy
observations of the linear diffusion equation (σ0 = 0.3). (F) Predictive mean of the linear
diffusion equation by GPs on lattice data with Matérn kernel.

manuscript. Panels (C) and (F) show that GPs with separable kernels effectively denoise
the lattice data and provide accurate estimates of the mean, even when the noise is large.

S7 Cell culturing and imaging for real data collection

The cell images used to develop this segmentation technique are of spindle-shaped human
dermal fibroblasts (hdFs), and the cells were cultured in Dulbecco’s modified eagle medium
supplemented with 1% Pen-Strep and 10% fetal bovine serum [6]. Prior to imaging, the
cytoplasm was stained with CellTracker deep red, and the nuclei were stained with Hoechst
33342.

At each time point when these microscopy images are acquired, scans of these cell
cultures were taken and stitched together, resulting in large composite images. Each scan
has two channels: a cytoplasm or whole cell channel and a nuclear channel. We compare
the benchmark ImageJ segmentation technique and the proposed GP-based method using
both channels. Further details of the images, including image dimensions, names, and
channels, can be found in Table S1.
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S8 Benchmark ImageJ segmentation steps for real data

analysis

ImageJ segmentation and boundary detection methods were utilized to evaluate the perfor-
mance of the unsupervised detection algorithm. The following image processing steps were
followed to generate the cell masks for the microscopy images tested in this article [10]:

1. Color Channel Splitting. When necessary, the color channels were split by se-
lecting from the Image menu Color → Split Channels. This operation divides
the image into red, green, and blue channels. All images provided were already in
grayscale format, so all channels were the same and matched the original image. For
consistency, the blue channel was always selected for further processing.

2. Brightness and Contrast Adjustment. The brightness and contrast of the
grayscale image were automatically adjusted by selecting from the Image menu Adjust

→ Brightness / Contrast→ Auto. With Imin being the smallest pixel value in the
image and Imax being the largest, each pixel I(xi,1, xj,2) is reset to I ′(xi,1, xj,2) =
I(xi,1,xj,2)−Imin

Imax−Imin
× 255. This function linearly rescales the image such that the pixel

values span the full range of possible values between 0 and 255, adding more contrast
and brightening the foreground pixels [4].

3. Binary Thresholding. The image was converted to binary format by selecting from
the Image menu Adjust → Threshold → Auto. The default method for setting the
threshold is a version of the IsoData method. In the IsoData method, after an initial
threshold is set, the averages for the pixel intensity values above (Tabove) and below
(Tbelow) the current threshold are taken, and the threshold is set to the composite
average (Tnew = Tabove+Tbelow

2
). This process is repeated until convergence [9]. The

default thresholding method in ImageJ first identifies and dampens dominant peaks
in the pixel intensity histogram values before applying the IsoData method, reducing
asymmetry in the histogram between the background pixel intensity peak and the
foreground pixel intensity peak. [10].

4. Noise Reduction. Once the image is thresholded to be binary, a despeckle operation
is run to reduce any noise (Noise→ Despeckle from the Process menu). Despeckle
applies a 3×3 median filter over the image, which replaces each pixel with the median
value of the surrounding pixels. This process helps reduce noise and smooth the image
[5].

5. Watershed Segmentation. To delineate touching cell nuclei, watershed is applied
using Binary→ Watershed from the Process menu. Watershed in ImageJ creates an
Euclidean distance map to give the distance of each foreground pixel to the nearest
background pixel and finds the ultimate eroded point(s) (UEPs) of each binary object
using an erode operation on the binary image. Water is simulated to “flood” the
image, with the UEPs as the seed points, and an edge is created where the water
from two UEPs converges [12].

6. Cell Mask Generation. Finally, the object is analyzed to extract the cell masks
using Analyze Particles from the Analyze menu. The parameters were set to
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detect objects with size 30-inf pixels2 and circularity 0-1.0. To detect cells in the
input image, the algorithm scans the image until it reaches the edge of an object (a
foreground pixel). It then traces around the edge of the object until the start point is
reached [3]. A true binary image can be generated by showing masks, and the masks
can be uniquely identified by showing count masks.

S9 Ground truth cell mask retrieval for real data anal-

ysis

The regions of interest (ROI) detected by the model zoos in the supervised learning al-
gorithm Cellpose were utilized as the starting point for generating the true cell masks for
each test image described in Table S1 [11]. The pretrained nuclei and cyto models were
used to generate the initial ROI for the nuclear and whole cell channels, respectively, of
the test grayscale images. The estimated cell diameter was kept at the default 30 pixels.
The resulting initial ROI were then refined by deleting erroneous and irregular cell masks
and adding masks for missed cells using the draw function (right-click) in the Cellpose
graphical user interface (GUI) [7], with the final output being the true masks. The true
masks are used to compare the accuracy of the GP-based segmentation method against the
benchmark ImageJ segmentation.

For illustration purposes, the corresponding boundary coordinates are determined by
retrieving the outer pixel coordinates of each cell mask object. The cell mask and boundary
data are made publicly available: https://github.com/UncertaintyQuantification/

cell_segmentation.

S10 Specifications of microscopy images

Table S1 contains the image name, dimensions, channel, and relevant figures for the images
used in this analysis. Multiple experimental images were cropped and sectioned to gener-
ate one or more smaller unique images for method testing, visualization, and analysis, as
the original images were too large for time-efficient computation and space-efficient visu-
alization. All images were taken during the experiments described in [6] and are publicly
available.
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Table S1: Name, dimensions, channel utilized, and relevant figures for the microscopy
images used in this study. These images can be found in the open-sourced dataset
associated with this article: https://github.com/UncertaintyQuantification/cell_

segmentation.

Image Name Dimensions Channel Relevant Figures

cropped img 1 488× 799 Nuclear 1

cropped img 2 488× 799 Nuclear 4, S5 (Cropped
section of im-
age shown and
analyzed)

cropped img 4 488× 799 Nuclear 2, 3, S3 (Cropped
section of im-
age shown and
analyzed)

cropped img 5 488× 799 Nuclear S4

nuclei 2 374× 250 Nuclear 7

whole cell 2 602× 600 Whole Cell 7

nuclei figure 1/original fig 962× 1128 Nuclear 9, S1, S2 (Test Im-
age 1)

nuclei figure 2/original fig 374× 250 Nuclear 9, S1, S2 (Test Im-
age 2)

nuclei figure 3/original fig 510× 492 Nuclear 9, S1, S2 (Test Im-
age 3)

nuclei figure 4/original fig 960× 608 Nuclear 9, S1, S2 (Test Im-
age 4)

nuclei figure 5/original fig 1024× 1024 Nuclear 9, S1, S2 (Test Im-
age 5)

whole cell figure 1/original fig 602× 600 Whole Cell 10 (Test Image 1)

whole cell figure 2/original fig 800× 800 Whole Cell 10 (Test Image 2)

whole cell figure 3/original fig 602× 600 Whole Cell 10 (Test Image 3)

whole cell figure 4/original fig 1000× 1000 Whole Cell 10 (Test Image 4)

whole cell figure 5/original fig 1000× 1000 Whole Cell 10 (Test Image 5)
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